On 2/11/22 20:19, Javier Martinez Canillas wrote:
[snip]
quoted
I would put GENMASK() directly into FIELD(), but it's up to you
(and I haven't checked the use of *_MASK anyway).
Same. I also considered just using GENMASK() directly, but since I was
already reworking these, I thought that having the _MASK constant macros
would make the code more explicit about these being masks and what for.
Just to make clear, I prefer to keep the GENMASK(n, n) and *_MASK here.
[snip]
quoted
quoted
+ bl = devm_backlight_device_register(dev, dev_name(dev), dev, ssd130x,
+ &ssd130xfb_bl_ops, NULL);
+ if (IS_ERR(bl))
+ return ERR_PTR(dev_err_probe(dev, PTR_ERR(bl),
+ "Unable to register backlight device\n"));
Can be consistent with this then.
Yes. I meant to change it everywhere but seems that one slipped it through.
It's not worth to send a v6 just for the changes you mentioned but I can do
them before pushing the patches to drm-misc (once I get ack for this patch).
Another option is to post a v6 only for patch 3/6 instead of all the patch-set.
Let me know what you prefer.
Best regards,
--
Javier Martinez Canillas
Linux Engineering
Red Hat