On Mon, 12 Aug 2019, Bjorn Helgaas wrote:
On Sun, Aug 11, 2019 at 06:07:55PM +0300, Denis Efremov wrote:
quoted
Code that iterates over all standard PCI BARs typically uses
PCI_STD_RESOURCE_END, but this is error-prone because it requires
"i <= PCI_STD_RESOURCE_END" rather than something like
"i < PCI_STD_NUM_BARS". We could add such a definition and use it the same
way PCI_SRIOV_NUM_BARS is used. There is already the definition
PCI_BAR_COUNT for s390 only. Thus, this patchset introduces it globally.
The patch is splitted into 7 parts for different drivers/subsystems for
easy readability.
This looks good. I can take all these together, since they all depend
on the first patch. I have a few comments on the individual patches.
quoted
Denis Efremov (7):
PCI: Add define for the number of standard PCI BARs
s390/pci: Replace PCI_BAR_COUNT with PCI_STD_NUM_BARS
x86/PCI: Use PCI_STD_NUM_BARS in loops instead of PCI_STD_RESOURCE_END
Fine with me for the x86 part. That's your turf anyway :)
Thanks,
tglx