[RESEND][PATCH 0/2] staging: sm750fb: trivial style fixes.

7 messages, 3 authors, 2019-03-20 · open the first message on its own page

[RESEND][PATCH 0/2] staging: sm750fb: trivial style fixes.

From: Yifeng Li <hidden>
Date: 2019-03-03 16:55:49

Hello.

From January to February, there have been two trivial sm750fb patches
submitted to linux-fbdev, one by me, one by Jin Chen, but both without
any response. Further, it seems both maintainers, Sudip Mukherjee and
Teddy Wang, are currently unavailable, getting an "Ack-by" would be
unfeasible.

Since they're extremely trivial. Hereby, I picked them up, reworded
commit message, and now resubmit them as trivial patches, and send them
to trivial@kernel.org. I hope it could be directly applied by either a
fbdev, a staging maintainer or by Jiri Kosina.

Thanks for your time!

Yifeng Li (2):
  staging: sm750fb: trivial comment indention fix.
  staging: sm750fb: trivial Camel Case removal for setDisplayControl().

 drivers/staging/sm750fb/ddk750_display.c |  6 ++---
 drivers/staging/sm750fb/sm750_accel.c    | 32 ++++++++++++------------
 2 files changed, 19 insertions(+), 19 deletions(-)

-- 
2.20.1

[RESEND][PATCH 1/2] staging: sm750fb: trivial comment indention fix.

From: Yifeng Li <hidden>
Date: 2019-03-03 16:55:53

In function sm750_hw_copyarea() of sm750_accel.c, there are
some comments in ASCII graphs, describing 4 possible scenarios
of overlapping areas when copying an area. However, the graphs
have broken indention.

The entire SiliconMotion series video controllers, including
SM501, SM712 and SM750 have similar 2D engines, yet, I have
not seen a single version of it with ASCII graphs properly
formatted...

Fix the the misleading ASCII graphs. It would eliminate the
confusions and improve code readability.

Signed-off-by: Yifeng Li <redacted>
---
 drivers/staging/sm750fb/sm750_accel.c | 32 +++++++++++++--------------
 1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750_accel.c b/drivers/staging/sm750fb/sm750_accel.c
index eed840b251da..dbcbbd1055da 100644
--- a/drivers/staging/sm750fb/sm750_accel.c
+++ b/drivers/staging/sm750fb/sm750_accel.c
@@ -155,26 +155,26 @@ unsigned int rop2)   /* ROP value */
 	if (sBase = dBase && sPitch = dPitch) {
 		/* Determine direction of operation */
 		if (sy < dy) {
-			/* +----------+
-			 * |S         |
-			 * |   +----------+
-			 * |   |      |   |
-			 * |   |      |   |
-			 * +---|------+   |
-			 * |         D|
-			 * +----------+
+			/*  +----------+
+			 *  |S         |
+			 *  |   +----------+
+			 *  |   |      |   |
+			 *  |   |      |   |
+			 *  +---|------+   |
+			 *	|         D|
+			 *	+----------+
 			 */
 
 			nDirection = BOTTOM_TO_TOP;
 		} else if (sy > dy) {
-			/* +----------+
-			 * |D         |
-			 * |   +----------+
-			 * |   |      |   |
-			 * |   |      |   |
-			 * +---|------+   |
-			 * |         S|
-			 * +----------+
+			/*  +----------+
+			 *  |D         |
+			 *  |   +----------+
+			 *  |   |      |   |
+			 *  |   |      |   |
+			 *  +---|------+   |
+			 *	|         S|
+			 *	+----------+
 			 */
 
 			nDirection = TOP_TO_BOTTOM;
-- 
2.20.1

[RESEND][PATCH 2/2] staging: sm750fb: trivial Camel Case removal for setDisplayControl().

From: Yifeng Li <hidden>
Date: 2019-03-03 16:56:00

Rename the function setDisplayControl() to set_display_control().
This fixes the following checkpatch.pl warning:

    CHECK: Avoid CamelCase: <setDisplayControl>

Suggested-by: Jin Chen <redacted>
Signed-off-by: Jin Chen <redacted>
[tomli@tomli.me: resent as trivial patch, reworded the commit message]
Signed-off-by: Yifeng Li <redacted>
---
 drivers/staging/sm750fb/ddk750_display.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/sm750fb/ddk750_display.c b/drivers/staging/sm750fb/ddk750_display.c
index 1273e7d18925..f38051eedb6c 100644
--- a/drivers/staging/sm750fb/ddk750_display.c
+++ b/drivers/staging/sm750fb/ddk750_display.c
@@ -5,7 +5,7 @@
 #include "ddk750_power.h"
 #include "ddk750_dvi.h"
 
-static void setDisplayControl(int ctrl, int disp_state)
+static void set_display_control(int ctrl, int disp_state)
 {
 	/* state != 0 means turn on both timing & plane en_bit */
 	unsigned long reg, val, reserved;
@@ -137,12 +137,12 @@ void ddk750_setLogicalDispOut(enum disp_output output)
 
 	if (output & PRI_TP_USAGE) {
 		/* set primary timing and plane en_bit */
-		setDisplayControl(0, (output & PRI_TP_MASK) >> PRI_TP_OFFSET);
+		set_display_control(0, (output & PRI_TP_MASK) >> PRI_TP_OFFSET);
 	}
 
 	if (output & SEC_TP_USAGE) {
 		/* set secondary timing and plane en_bit*/
-		setDisplayControl(1, (output & SEC_TP_MASK) >> SEC_TP_OFFSET);
+		set_display_control(1, (output & SEC_TP_MASK) >> SEC_TP_OFFSET);
 	}
 
 	if (output & PNL_SEQ_USAGE) {
-- 
2.20.1

Re: [RESEND][PATCH 0/2] staging: sm750fb: trivial style fixes.

From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2019-03-03 17:57:14

On Mon, Mar 04, 2019 at 12:55:30AM +0800, Yifeng Li wrote:
Hello.
quoted
From January to February, there have been two trivial sm750fb patches
submitted to linux-fbdev, one by me, one by Jin Chen, but both without
any response. Further, it seems both maintainers, Sudip Mukherjee and
Teddy Wang, are currently unavailable, getting an "Ack-by" would be
unfeasible.

Since they're extremely trivial. Hereby, I picked them up, reworded
commit message, and now resubmit them as trivial patches, and send them
to trivial@kernel.org. I hope it could be directly applied by either a
fbdev, a staging maintainer or by Jiri Kosina.

Thanks for your time!

Yifeng Li (2):
  staging: sm750fb: trivial comment indention fix.
  staging: sm750fb: trivial Camel Case removal for setDisplayControl().

 drivers/staging/sm750fb/ddk750_display.c |  6 ++---
 drivers/staging/sm750fb/sm750_accel.c    | 32 ++++++++++++------------
 2 files changed, 19 insertions(+), 19 deletions(-)
Always use scripts/get_maintainer.pl when sending patches in.  It would
have saved you time...

Anyway, my tree is closed right now, but I'll look at these once 5.1-rc1
is out, thanks.

greg k-h

Re: [RESEND][PATCH 2/2] staging: sm750fb: trivial Camel Case removal for setDisplayControl().

From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2019-03-07 20:22:39

On Mon, Mar 04, 2019 at 12:55:32AM +0800, Yifeng Li wrote:
Rename the function setDisplayControl() to set_display_control().
This fixes the following checkpatch.pl warning:

    CHECK: Avoid CamelCase: <setDisplayControl>

Suggested-by: Jin Chen <redacted>
Signed-off-by: Jin Chen <redacted>
[tomli@tomli.me: resent as trivial patch, reworded the commit message]
Signed-off-by: Yifeng Li <redacted>
I've already applied Jin's patch to the tree, so no need to resend this.

thanks,

greg k-h

Re: [RESEND][PATCH 0/2] staging: sm750fb: trivial style fixes.

From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2019-03-20 05:14:02

On Mon, Mar 04, 2019 at 12:55:30AM +0800, Yifeng Li wrote:
Hello.
quoted
From January to February, there have been two trivial sm750fb patches
submitted to linux-fbdev, one by me, one by Jin Chen, but both without
any response. Further, it seems both maintainers, Sudip Mukherjee and
Teddy Wang, are currently unavailable, getting an "Ack-by" would be
unfeasible.

Since they're extremely trivial. Hereby, I picked them up, reworded
commit message, and now resubmit them as trivial patches, and send them
to trivial@kernel.org. I hope it could be directly applied by either a
fbdev, a staging maintainer or by Jiri Kosina.
staging patches need to go to me, as get_maintainers.pl says to send
them.  I'll queue these up in a bit, but no need to bother trivial@ with
staging stuff, otherwise that would be all it did :)

thanks,

greg k-h

Re: [RESEND][PATCH 2/2] staging: sm750fb: trivial Camel Case removal for setDisplayControl().

From: Dan Carpenter <hidden>
Date: 2019-03-20 12:36:49

On Mon, Mar 04, 2019 at 12:55:32AM +0800, Yifeng Li wrote:
Rename the function setDisplayControl() to set_display_control().
This fixes the following checkpatch.pl warning:

    CHECK: Avoid CamelCase: <setDisplayControl>

Suggested-by: Jin Chen <redacted>
Signed-off-by: Jin Chen <redacted>
[tomli@tomli.me: resent as trivial patch, reworded the commit message]
Signed-off-by: Yifeng Li <redacted>
---
Apparently Greg already applied this earlier...  I don't know why the
original patch didn't reach me.  I'm on the devel@driverdev.osuosl.org
list.

Did Jin Chen write this?  If so why does it have a Suggested-by tag for
him?  If not then you should have preserved the authorship credit by
using the From: header in the first line on the commit message...

Anyway, it doesn't matter but hopefully this helps for next time.

regards,
dan carpenter
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help