Thread (5 messages) 5 messages, 5 authors, 2018-07-24

Re: [PATCH v2 fbdev-for-next 1/2] fbcon: introduce for_each_registered_fb() helper

From: Bartlomiej Zolnierkiewicz <hidden>
Date: 2018-07-24 15:18:35
Also in: dri-devel, lkml

On Saturday, June 30, 2018 03:29:49 PM Yisheng Xie wrote:
Following pattern is often used:

 for (i = 0; i < FB_MAX; i++) {
        if (registered_fb[i]) {
                ...
        }
 }

Therefore, as Andy's suggestion, for_each_registered_fb() helper can
be introduced to make the code easier to read and write by reducing
indentation level. It also saves few lines of code in each occurrence.

This patch convert all part here at the same time.

Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Signed-off-by: Yisheng Xie <redacted>
Patch queued for 4.19, thanks.

Best regards,
--
Bartlomiej Zolnierkiewicz
Samsung R&D Institute Poland
Samsung Electronics
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help