Thread (4 messages) flat view 4 messages, 4 authors, 2017-03-22

Re: staging: iio: Replace a bit shift by a use of BIT.

From: Arnd Bergmann <arnd@arndb.de>
Date: 2017-03-22 08:53:35
Also in: lkml

On Wed, Mar 22, 2017 at 3:49 AM, Arushi Singhal
[off-list ref] wrote:
quoted hunk ↗ jump to hunk
@@ -232,7 +232,7 @@ static int ad7150_write_event_config(struct iio_dev *indio_dev,
        if (ret < 0)
                goto error_ret;

-       cfg = ret & ~((0x03 << 5) | (0x1 << 7));
+       cfg = ret & ~((0x03 << 5) | (BIT(7)));

        switch (type) {
        case IIO_EV_TYPE_MAG_ADAPTIVE:
While the change in the #defines is not unusual, this particular change
here makes it harder to read, so I'd recommend leaving it alone, or changing
it to use symbolic names instead of the bit masks.
 /* Voltage/Temperature Setup Register Bit Designations (AD7746_REG_VT_SETUP) */
-#define AD7746_VTSETUP_VTEN            (1 << 7)
+#define AD7746_VTSETUP_VTEN            (BIT(7))
 #define AD7746_VTSETUP_VTMD_INT_TEMP   (0 << 5)
-#define AD7746_VTSETUP_VTMD_EXT_TEMP   (1 << 5)
+#define AD7746_VTSETUP_VTMD_EXT_TEMP   (BIT(5))
Why did you leave one of them unchanged?

    Arnd
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help