Re: [PATCH v4] staging: sm750fb: Code readability is improved
From: Dan Carpenter <hidden>
Date: 2017-03-20 13:07:27
Also in:
lkml
On Mon, Mar 20, 2017 at 06:25:19PM +0530, Arushi Singhal wrote:
On Mon, Mar 20, 2017 at 5:58 PM, Dan Carpenter [off-list ref] wrote:quoted
On Sun, Mar 19, 2017 at 09:19:20PM +0530, Arushi Singhal wrote:quoted
New variables are added to make the code more readable. Signed-off-by: Arushi Singhal <redacted> --- changes in v4 -try to make the code much more readable. - defined the variable at the top of a block. --- drivers/staging/sm750fb/ddk750_mode.c | 57+++++++++++++++++++----------------quoted
1 file changed, 31 insertions(+), 26 deletions(-)diff --git a/drivers/staging/sm750fb/ddk750_mode.cb/drivers/staging/sm750fb/ddk750_mode.cquoted
index eea5aef2956f..6517e770e0a7 100644--- a/drivers/staging/sm750fb/ddk750_mode.c +++ b/drivers/staging/sm750fb/ddk750_mode.c@@ -76,38 +76,43 @@ static int programModeRegisters(mode_parameter_t*pModeParam, struct pll_value *quoted
{ int ret = 0; int cnt = 0; - unsigned int tmp, reg; + unsigned int tmp, reg, temp;Let's not have "tmp" and "temp" both. Generally "tmp" is better because you can't confuse it with temperature.Hi Dan I have not added the tmp variable. So is it good to use any other variable like "a" instead of temp.
Just re-use "tmp". No need to add "temp". regards, dan carpenter