Hi
On Thu, Jan 23, 2014 at 6:14 PM, Ingo Molnar [off-list ref] wrote:
* David Herrmann [off-list ref] wrote:
quoted
quoted
quoted
+#ifdef CONFIG_X86_SYSFB
+# include <asm/sysfb.h>
+#endif
I guess a single space is sufficient?
Better yet, I'd include sysfb.h unconditionally:
Unconditionally won't work as only x86 has this header. [...]
Well, in non-x86 code an #ifdef x86 looks ugly as well - but I guess
better than not building.
quoted
[...] If there's a way to place a dummy into asm-generic which is
picked if arch/xy/include/asm/ doesn't have the header, let me know.
Not that I know of.
quoted
But if I include it unconditionally without any fallback, this will
fail on non-x86. And adding the header to all archs seems overkill.
So why not drop the x86-ism and rename it to CONFIG_PLATFORM_SYSFB?
Some platforms configure it, some don't. Then the prototypes could
move into include/linux/sysfb.h or so and would be platform agnostic.
This is almost exactly what patch #6 does. But it also adds ~400 lines
of kernel-doc and ~400 lines of Documentation/. Given your remarks, I
guess I will just split this patch into code and docs, so we can just
pick it up for stable in case patch #1 does not fix all issues.
Thanks
David