Thread (9 messages) 9 messages, 5 authors, 2014-02-21

Re: [PATCH v5] video: add OpenCores VGA/LCD framebuffer driver

flat view

From: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
Date: 2014-01-13 06:20:01
Also in: lkml

On Mon, Jan 13, 2014 at 10:24:49AM +0900, Jingoo Han wrote:
On Saturday, January 11, 2014 5:13 AM, Stefan Kristiansson wrote:
quoted
+#include <linux/module.h>
+#include <linux/kernel.h>
+#include <linux/errno.h>
+#include <linux/string.h>
+#include <linux/slab.h>
+#include <linux/delay.h>
+#include <linux/mm.h>
+#include <linux/dma-mapping.h>
+#include <linux/fb.h>
+#include <linux/init.h>
+#include <linux/io.h>
+#include <linux/platform_device.h>
+#include <linux/of.h>
Would you re-order these headers alphabetically?
It enhances the readability.
OK
[.....]
quoted
+struct ocfb_dev {
+	struct fb_info info;
+	void __iomem *regs;
+	/* flag indicating whether the regs are little endian accessed */
+	int little_endian;
+	/* Physical and virtual addresses of framebuffer */
+	phys_addr_t fb_phys;
+	void __iomem *fb_virt;
+	u32 pseudo_palette[PALETTE_SIZE];
+};
Here, 'fb_virt' is already defined as 'void __iomem *'.

[.....]
quoted
+	fbdev->info.fix.smem_start = fbdev->fb_phys;
+	fbdev->info.screen_base = (void __iomem *)fbdev->fb_virt;
Please remove unnecessary casting as below, because 'fb_virt' is already
defined as 'void __iomem *'.

+	fbdev->info.screen_base = fbdev->fb_virt;
quoted
+	fbdev->info.pseudo_palette = fbdev->pseudo_palette;
+
+	/* Clear framebuffer */
+	memset_io((void __iomem *)fbdev->fb_virt, 0, fbsize);
Same here.

+	memset_io(fbdev->fb_virt, 0, fbsize);
Nice catch, will do.

Stefan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help