Thread (5 messages) flat view 5 messages, 3 authors, 2013-09-19

Re: [PATCH] pwm-backlight: allow for non-increasing brightness levels

From: Thierry Reding <hidden>
Date: 2013-09-19 11:58:10
Also in: linux-devicetree, linux-pwm, lkml

On Thu, Sep 12, 2013 at 11:35:52AM -0700, Mike Dunn wrote:
Currently the driver assumes that the values specified in the brightness-levels
device tree property increase as they are parsed from left to right.  But boards
that invert the signal between the PWM output and the backlight will need to
specify decreasing brightness-levels.  This patch removes the assumption that
the last element of the array is the max value, and instead searches the array
for the max value and uses that as the normalizing value when determining the
duty cycle.
"maximum value", "... and uses that as the scale to normalize the duty
cycle"?

Also please wrap commit messages at 72 characters.
quoted hunk ↗ jump to hunk
diff --git a/drivers/video/backlight/pwm_bl.c b/drivers/video/backlight/pwm_bl.c
index 1fea627..d66aaa0 100644
--- a/drivers/video/backlight/pwm_bl.c
+++ b/drivers/video/backlight/pwm_bl.c
@@ -27,6 +27,7 @@ struct pwm_bl_data {
 	unsigned int		period;
 	unsigned int		lth_brightness;
 	unsigned int		*levels;
+	unsigned int		max_level;
Perhaps call this "scale"? Otherwise there some potential to mix it up
with max_brightness.
quoted hunk ↗ jump to hunk
@@ -195,7 +196,15 @@ static int pwm_backlight_probe(struct platform_device *pdev)
 	}
 
 	if (data->levels) {
-		max = data->levels[data->max_brightness];
+		int i, max_value = 0, max_idx = 0;
i should be unsigned int to match the type of data->max_brightness.
+		for (i = 0; i <= data->max_brightness; i++) {
There should be a blank line above this one to increase readability.
+			if (data->levels[i] > max_value) {
+				max_value = data->levels[i];
+				max_idx = i;
+			}
+		}
+		pb->max_level = max_idx;
Some here.

Also I suggest to just drop the max_ prefix from the local variables.
Perhaps also simplify all of it to something like:

	for (i = 0; i <= data->max_brightness; i++)
		if (data->levels[i] > pb->scale)
			pb->scale = data->levels[i];

And get rid of the index altogether. That way you can use pb->scale
directly during the computation of the duty cycle and don't have to
index the levels array over and over again.

Thierry

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help