Thread (23 messages) 23 messages, 7 authors, 2012-11-09

Re: [PATCH v7 2/8] of: add helper to parse display timings

From: Thierry Reding <hidden>
Date: 2012-11-01 20:15:10
Also in: dri-devel, linux-devicetree, linux-media

On Wed, Oct 31, 2012 at 10:28:02AM +0100, Steffen Trumtrar wrote:
[...]
quoted hunk ↗ jump to hunk
diff --git a/Documentation/devicetree/bindings/video/display-timings.txt b/Documentation/devicetree/bindings/video/display-timings.txt
[...]
quoted hunk ↗ jump to hunk
@@ -0,0 +1,139 @@
+display-timings bindings
+==================
+
+display-timings-node
+------------
Maybe extend the underline to the length of the section and subsection
titles respectively?
+struct display_timing
+===================
Same here.
+config OF_DISPLAY_TIMINGS
+	def_bool y
+	depends on DISPLAY_TIMING
Maybe this should be called OF_DISPLAY_TIMING to match DISPLAY_TIMING,
or rename DISPLAY_TIMING to DISPLAY_TIMINGS for the sake of consistency?
+/**
+ * of_get_display_timing_list - parse all display_timing entries from a device_node
+ * @np: device_node with the subnodes
+ **/
+struct display_timings *of_get_display_timing_list(struct device_node *np)
Perhaps this would better be named of_get_display_timings() to match the
return type?
+	disp = kzalloc(sizeof(*disp), GFP_KERNEL);
Shouldn't you be checking this for allocation failures?
+	disp->timings = kzalloc(sizeof(struct display_timing *)*disp->num_timings,
+				GFP_KERNEL);
Same here.

Thierry

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help