Thread (71 messages) 71 messages, 4 authors, 2012-09-06

Re: [PATCH 1/6] OMAPDSS: DISPC: cleanup cpu_is_xxxx checks

From: Tomi Valkeinen <hidden>
Date: 2012-08-14 12:16:19
Also in: linux-omap

On Tue, 2012-08-14 at 17:33 +0530, Mahapatra, Chandrabhanu wrote:
quoted
+static const struct __initdata dispc_features omap2_dispc_features = {
+       .hp_max                 =       256,
+       .vp_max                 =       255,
+       .sw_max                 =       64,
+       .sw_start               =       5,
+       .fp_start               =       15,
+       .bp_start               =       27,
+       .calc_scaling           =       dispc_ovl_calc_scaling_24xx,
+       .calc_core_clk          =       calc_core_clk_24xx,
+};
+
+static const struct __initdata dispc_features omap3_2_1_dispc_features = {
+       .hp_max                 =       256,
+       .vp_max                 =       255,
+       .sw_max                 =       64,
+       .sw_start               =       5,
+       .fp_start               =       15,
+       .bp_start               =       27,
+       .calc_scaling           =       dispc_ovl_calc_scaling_34xx,
+       .calc_core_clk          =       calc_core_clk_34xx,
+};
+
+static const struct __initdata dispc_features omap3_3_0_dispc_features = {
+       .hp_max                 =       4096,
+       .vp_max                 =       4095,
+       .sw_max                 =       256,
+       .sw_start               =       7,
+       .fp_start               =       19,
+       .bp_start               =       31,
+       .calc_scaling           =       dispc_ovl_calc_scaling_34xx,
+       .calc_core_clk          =       calc_core_clk_34xx,
+};
+
+static const struct __initdata dispc_features omap4_dispc_features = {
+       .hp_max                 =       4096,
+       .vp_max                 =       4095,
+       .sw_max                 =       256,
+       .sw_start               =       7,
+       .fp_start               =       19,
+       .bp_start               =       31,
+       .calc_scaling           =       dispc_ovl_calc_scaling_44xx,
+       .calc_core_clk          =       calc_core_clk_44xx,
+};
+
Here the dispc_features not only mention the omap name but also the
revision like omap3_3_0_dispc_features which initializes data for
OMAP3430_REV_ES3_0 and higher. May be omap34xx_rev3_0_dispc_features
is a better name for this. For others omap44xx_dispc_features kind of
name should be ok without revision number being mentioned. What d you
say?
Sounds ok to me.

 Tomi

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help