Thread (5 messages) flat view 5 messages, 3 authors, 2008-10-30

Re: [PATCH RESEND] vgacon: remember scrollback buffer on console switch

From: Andrew Morton <akpm@linux-foundation.org>
Date: 2008-10-25 23:15:37
Also in: lkml

On Sun, 26 Oct 2008 00:43:01 +0200 Marcin Slusarz [off-list ref] wrote:
PS: why DECLARE_MUTEX _defines_ _semaphore_?
The kernel gets definition-vs-declaration confused in several places.
there are only 8 uses of this
macro so it's not a big problem to rename it to e.g. DEFINE_SEMAPHORE (I can
provide a patch)
I'd say that s/declare/define/ at such a late stage in the semaphore's
lifetime would be of dubious value.  But getting "MUTEX" out of that
macro's name would be a very good thing - it's a bad overlap with struct
mutex.  Send patch :)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help