Re: Re: fbdv/fbcon pending problems
From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: 2004-02-24 08:38:53
Also in:
lkml
On Tue, 24 Feb 2004, Benjamin Herrenschmidt wrote:
On Tue, 2004-02-24 at 05:59, James Simmons wrote:quoted
I think we should do better validating of the var passed in. This also needs a bit of work.It does. Radeonfb did one step in this direction, but that's not enough. _BUT_ we still need to differenciate between a full mode passed from userland from a mode where we _KNOW_ everything is bogus but width/height... In the later case, we really want to find a mode that is just large enough for the passed in width/height (but not smaller, or just fail if not found) and with the same hfreq if possible as the current mode. That's really a different request than a full blown mode coming from userland (like a 'tuning' tool or whatever...) The FB_ACTIVATE_FIND is just that. It justs tells the driver to pick up a mode based on width/height only. We know the rest of the var is bogus.
What about renaming it to FB_ACTIVE_RESIZE?
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
-------------------------------------------------------
SF.Net is sponsored by: Speed Start Your Linux Apps Now.
Build and deploy apps & Web services for Linux with
a free DVD software kit from IBM. Click Now!
http://ads.osdn.com/?ad_id=1356&alloc_id=3438&op=click