On Wed, Oct 13, 2021 at 07:10:13AM +0200, Christoph Hellwig wrote:
I wondered about adding a helper for looking at the size in byte units
to avoid the SECTOR_SHIFT shifts in various places. But given that
I could not come up with a good name and block devices fundamentally
work in sector size granularity I decided against that.
So it seems like the biggest review feedback is that we should have
such a helper. I think the bdev_size name is the worst as size does
not imply a particular unit. bdev_nr_bytes is a little better but I'm
not too happy. Any other suggestions or strong opinions?