On Tue, Jan 12, 2021 at 11:00:57PM +0100, Christian Brauner wrote:
Add a simple helper to retrieve the user namespace associated with the
vfsmount of a file. Christoph correctly points out that this makes
codepaths (e.g. ioctls) way easier to follow that would otherwise
dereference via mnt_user_ns(file->f_path.mnt).
In order to make file_user_ns() static inline we'd need to include
mount.h in either file.h or fs.h which seems undesirable so let's simply
not force file_user_ns() to be inline.
I'd be tempted to just make this an inline.
Otherwise this looks ok:
Reviewed-by: Christoph Hellwig <hch@lst.de>