Re: [PATCH v2 2/3] ext4: Rename ext4_kvmalloc() to ext4_kvmalloc_nofs() and drop its flags argument
From: Jan Kara <jack@suse.cz>
Date: 2020-01-16 12:37:26
From: Jan Kara <jack@suse.cz>
Date: 2020-01-16 12:37:26
On Mon 13-01-20 17:32:37, Theodore Y. Ts'o wrote:
On Fri, Dec 27, 2019 at 05:05:22PM +0900, Naoto Kobayashi wrote:quoted
Rename ext4_kvmalloc() to ext4_kvmalloc_nofs() and drop its flags argument, because ext4_kvmalloc() callers must be under GFP_NOFS (otherwise, they should use generic kvmalloc() helper function). Signed-off-by: Naoto Kobayashi <redacted>Thanks, applied.
Ted, I don't think this patch is needed at all - see my email [1]. Sadly Naoto didn't reply to my question whether he really saw any deadlock / lockdep splat or whether it was just a theoretical concern he had... Honza [1] https://lore.kernel.org/linux-ext4/20200109100007.GC27035@quack2.suse.cz (local) -- Jan Kara [off-list ref] SUSE Labs, CR