Thread (8 messages) 8 messages, 6 authors, 2018-11-30

Re: [PATCH 2/2] fs: Don't open-code lru_to_page

From: Michal Hocko <mhocko@kernel.org>
Date: 2018-11-29 09:04:57
Also in: ceph-devel, linux-btrfs, linux-cifs, linux-mm, lkml

On Thu 29-11-18 10:50:08, Nikolay Borisov wrote:

On 29.11.18 г. 10:18 ч., Michal Hocko wrote:
quoted
On Thu 29-11-18 09:52:57, Nikolay Borisov wrote:
quoted
There are a bunch of filesystems which essentially open-code lru_to_page
helper. Change them to using the helper. No functional changes.
I would just squash the two into a single patch. It makes the first one
more obvious. Or is there any reason to have them separate?
No reason, just didn't know how people would react so that's why I chose
to send as two separate.
This is a matter of taste I guess. But I usually prefer to have callers
along with a new helper in a single patch. This is not a new helper
per-se but doing it the same way seems reasonable to me. Not that I
would insist of course. You can use my ack for both patch in case you
decide to leave it as is.
If I squash them who would be the best person to take them ?
Sounds like a mmotm material to me.
-- 
Michal Hocko
SUSE Labs
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help