Re: [PATCH 2/4 v3] fiemap: add EXTENT_DATA_COMPRESSED flag
From: David Sterba <hidden>
Date: 2014-07-24 19:22:45
Also in:
linux-btrfs, linux-fsdevel, linux-xfs, ocfs2-devel
On Thu, Jul 17, 2014 at 12:07:57AM -0600, Andreas Dilger wrote:
any progress on this patch series?
I'm sorry I got distracted at the end of year and did not finish the series.
I never saw an updated version of this patch series after the last round of reviews, but it would be great to move it forward. I have filefrag patches in my e2fsprogs tree waiting for an updated version of your patch. I recall the main changes were: - add FIEMAP_EXTENT_PHYS_LENGTH flag to indicate if fe_phys_length was valid
fe_phys_length will be always valid, so other the flags are set only if it's not equal to the logical length.
- rename fe_length to fe_logi_length and #define fe_length fe_logi_length - always fill in fe_phys_length (= fe_logi_length for uncompressed files) and set FIEMAP_EXTENT_PHYS_LENGTH whether the extent is compressed or not
This is my understanding and contradicts the first point.
- add WARN_ONCE() in fiemap_fill_next_extent() as described below I don't know if there was any clear statement about whether there should be separate FIEMAP_EXTENT_PHYS_LENGTH and FIEMAP_EXTENT_DATA_COMPRESSED flags, or if the latter should be implicit? Probably makes sense to have separate flags. It should be fine to use: #define FIEMAP_EXTENT_PHYS_LENGTH 0x00000010 since this flag was never used.
I've kept only FIEMAP_EXTENT_DATA_COMPRESSED, I don't see a need for FIEMAP_EXTENT_PHYS_LENGTH and this would be yet another flag because the FIEMAP_EXTENT_DATA_ENCODED is also implied. I'll send V4, we can discuss the PHYS_LENGTH flag then. -- To unsubscribe from this list: send the line "unsubscribe linux-nilfs" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html