Re: [PATCH v3] ext4: make quota as first class supported feature
From: Johann Lombardi <hidden>
Date: 2011-11-07 20:39:37
On Fri, Nov 04, 2011 at 10:43:10AM -0700, Aditya Kali wrote:
On Fri, Nov 4, 2011 at 2:20 AM, Johann Lombardi [off-list ref] wrote:quoted
On Thu, Nov 03, 2011 at 07:15:20PM -0700, Aditya Kali wrote:quoted
+#ifdef CONFIG_QUOTA + /* Enable quota usage during mount. */ + if (EXT4_HAS_RO_COMPAT_FEATURE(sb, EXT4_FEATURE_RO_COMPAT_QUOTA) && + !(sb->s_flags & MS_RDONLY)) { + ext4_quota_enable(sb, USRQUOTA, QFMT_VFS_V1, + DQUOT_USAGE_ENABLED); + ext4_quota_enable(sb, GRPQUOTA, QFMT_VFS_V1, + DQUOT_USAGE_ENABLED);I think we should print an error message if one of the calls to ext4_quota_enable() failed. Space accounting in the quota files won't be accurate any more and e2fsck is required.Are you suggesting that we mark the filesystem has having errors if this fails (use ext4_error() ) or simply print a warning in dmesg?
A warning in dmesg is the least we could do IMHO. Marking the filesystem as having errors would be even better, i think. BTW, we have the same problem if CONFIG_QUOTA is not defined.
I am currently marking the filesystem as having errors if ext4_iget() fails for the quota inode. But dquot_enable() could fail for other reasons too (specially if we allow using user-specified quota files).
Cheers, Johann -- To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html