Re: [PATCH 1/5] jbd2: Pass extra bool parameter in journal routines to specify if its ok to fail the journal transaction allocation.
From: Manish Katiyar <hidden>
Date: 2011-05-13 06:37:25
Hi Jan, Thanks for your patient feedback. On Wed, May 11, 2011 at 8:54 AM, Jan Kara [off-list ref] wrote:
Hi, sorry I got to your patches with a delay. One general note - please do not attach patches. It is enough to have them in the email... On Sun 24-04-11 17:10:41, Manish Katiyar wrote:quoted
Pass extra bool parameter in journal routines to specify if its ok to fail the journal transaction allocation. If 'true' is passed transaction allocation is done through GFP_KERNEL and ENOMEM is returned else GFP_NOFS is used.Please, do not mix error handling with gfp masks. Instead just rename jbd2__journal_start() to jbd2_journal_start() and change gfp_mask parameter to "bool errok".
ok.
Use GFP_NOFS gfp mask for start_this_handle().
I think I didn't completely understand this line. You meant passing GFP_KERNEL or GFP_NOFS based on errok right ?
Also your patch series should be bisectable - that means it must compile and run after any of the patches. So you cannot really change jbd2_journal_start() prototype without changing all the filesystems using it. In this case, just include in this patch a simple change for ext4 and ocfs2 to pass 'false' in the additional argument.
ok.. Will submit the first patch as everyone passing false as the errok argument. -- Thanks - Manish -- To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html