Thread (28 messages) flat view 28 messages, 3 authors, 2026-02-10

Re: [v4,net-next,01/11] net/nebula-matrix: add minimum nbl build framework

From: Jakub Kicinski <kuba@kernel.org>
Date: 2026-02-07 02:24:47
Also in: lkml, netdev

This is an AI-generated review of your patch. The human sending this
email says "This is an automated AI code reviewer, please treat what
it says with a grain of salt."

For local reproduction steps see https://netdev-ai.bots.linux.dev/ai-local.html
---
net/nebula-matrix: add minimum nbl build framework

This commit adds the minimal build infrastructure for the Nebula-Matrix
M18100-NIC family driver, including Kconfig, Makefiles, documentation,
and stub PCI driver functions.
quoted hunk ↗ jump to hunk
diff --git a/Documentation/networking/device_drivers/ethernet/index.rst b/Documentation/networking/device_drivers/ethernet/index.rst
--- a/Documentation/networking/device_drivers/ethernet/index.rst
+++ b/Documentation/networking/device_drivers/ethernet/index.rst
@@ -48,6 +48,7 @@
   meta/fbnic
   microsoft/netvsc
   mucse/rnpgbe
+   nebula-matrix/nbl
   netronome/nfp
The documentation index references 'nebula-matrix/nbl' but the actual file
created is 'nebula-matrix/m18100.rst'. This will cause 'make htmldocs' to fail
with a broken reference.

Simon Horman flagged this in v3 review:
https://lore.kernel.org/netdev/aXj_f3hsMmvKxC26@horms.kernel.org/ (local)

Should this be 'nebula-matrix/m18100' instead?
quoted hunk ↗ jump to hunk
diff --git a/drivers/net/ethernet/nebula-matrix/Kconfig b/drivers/net/ethernet/nebula-matrix/Kconfig
--- /dev/null
+++ b/drivers/net/ethernet/nebula-matrix/Kconfig
[ ... ]
+config NBL_CORE
+	tristate "Nebula-matrix Ethernet Controller m18100 Family support"
Andrew Lunn raised concerns about the NBL_CORE naming in multiple versions of
this patch series. The "_CORE" suffix is typically reserved for libraries shared
by multiple drivers that use 'select' rather than having a tristate prompt.

If this module provides Ethernet functionality directly, the naming convention
would be to call it an Ethernet driver rather than "core".

See v1 and v3 review comments:
https://lore.kernel.org/netdev/88c7e349-f941-4216-89ca-70a49e82b378@lunn.ch/ (local)

Is there a reason to keep the _CORE suffix, or could this follow standard driver
naming conventions?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help