On Fri, 5 Dec 2025 11:18:39 +0000
Tvrtko Ursulin [off-list ref] wrote:
On 05/12/2025 09:12, Loïc Molinari wrote:
quoted
Make use of the new drm_gem_huge_mnt_create() and
drm_gem_get_huge_mnt() helpers to avoid code duplication. Now that
it's just a few lines long, the single function in i915_gemfs.c is
moved into i915_gem_shmem.c.
v3:
- use huge tmpfs mountpoint in drm_device
- move i915_gemfs.c into i915_gem_shmem.c
v4:
- clean up mountpoint creation error handling
v5:
- use drm_gem_has_huge_mnt() helper
v7:
- include <drm/drm_print.h> in i915_gem_shmem.c
v8:
- keep logging notice message with CONFIG_TRANSPARENT_HUGEPAGE=n
- don't access huge_mnt field with CONFIG_TRANSPARENT_HUGEPAGE=n
v9:
- replace drm_gem_has_huge_mnt() by drm_gem_get_huge_mnt()
- remove useless ternary op test in selftests/huge_pages.c
v12:
- fix layering violation in selftests (Tvrtko)
- fix incorrect filename in commit message
Thanks, looks good to me.
Acked-by: Tvrtko Ursulin <redacted>
What are your plans for landing the series? Presumably you'd like to do
it in one go via drm-misc-next rather than in stages and different trees?
Yep, ideally this would go through drm-misc-next.