Re: [PATCH 01/12] iomap: pass more arguments using the iomap writeback context
From: Joanne Koong <joannelkoong@gmail.com>
Date: 2025-07-02 22:00:54
Also in:
gfs2, linux-block, linux-fsdevel, linux-xfs
On Wed, Jul 2, 2025 at 11:18 AM Darrick J. Wong [off-list ref] wrote:
On Mon, Jun 30, 2025 at 08:41:13AM -0400, Brian Foster wrote:quoted
On Mon, Jun 30, 2025 at 07:44:07AM +0200, Christoph Hellwig wrote:quoted
On Fri, Jun 27, 2025 at 11:12:20AM -0400, Brian Foster wrote:quoted
I find it slightly annoying that the struct name now implies 'wbc,' which is obviously used by the writeback_control inside it. It would be nice to eventually rename wpc to something more useful, but that's for another patch:True, but wbc is already taken by the writeback_control structure. Maybe I should just drop the renaming for now?Yeah, that's what makes it confusing IMO. writeback_ctx looks like it would be wbc, but it's actually wpc and wbc is something internal. But I dunno.. it's not like the original struct name is great either. I was thinking maybe rename the wpc variable name to something like wbctx (or maybe wbctx and wbctl? *shrug*). Not to say that is elegant by any stretch, but just to better differentiate from wbc/wpc and make the code a little easier to read going forward. I don't really have a strong opinion wrt this series so I don't want to bikeshed too much. Whatever you want to go with is fine by me.I'd have gone with iwc or iwbc, but I don't really care that much. :) Now I'm confused because I've now seen the same patch from joanne and hch and don't know which one is going forward. Maybe I should just wait for a combined megaseries...
Christoph's is the main source of truth and mine is just pulling his patches and putting the fuse changes on top of that :) For the v3 fuse iomap patchset [1], the iomap patches in that were taken verbatim from his "refactor the iomap writeback code v2" patchset [2]. [1] https://lore.kernel.org/linux-fsdevel/20250624022135.832899-1-joannelkoong@gmail.com/ (local) [2] https://lore.kernel.org/linux-fsdevel/20250617105514.3393938-1-hch@lst.de/ (local)
--Dquoted
Brian