On Tue, Jun 13, 2023 at 10:20:31AM -0700, Elliot Berman wrote:
quoted hunk ↗ jump to hunk
diff --git a/include/linux/gunyah.h b/include/linux/gunyah.h
[..]
+/******************************************************************************/
+/* Common arch-independent definitions for Gunyah hypercalls */
+#define GH_CAPID_INVAL U64_MAX
+#define GH_VMID_ROOT_VM 0xff
+
+enum gh_error {
"gh_" happens to be an unused prefix in the Linux kernel, but I find it
to be an unnatural abbreviation of "gunyah".
I would therefor prefer to have it expanded to "gunyah" for all
functions, macros and data types throughout the implementation.
Regards,
Bjorn