Thread (47 messages) 47 messages, 7 authors, 2022-03-01

Re: [PATCH v1 7/7] fpga: dfl: pci: Add generic OFS PCI PID

From: Tom Rix <trix@redhat.com>
Date: 2022-02-18 15:27:15
Also in: linux-fpga, lkml

On 2/18/22 1:03 AM, Zhang, Tianfei wrote:
quoted
-----Original Message-----
From: Tom Rix <trix@redhat.com>
Sent: Wednesday, February 16, 2022 12:16 AM
To: Zhang, Tianfei <redacted>; Wu, Hao <redacted>;
mdf@kernel.org; Xu, Yilun [off-list ref]; linux-fpga@vger.kernel.org;
linux-doc@vger.kernel.org; linux-kernel@vger.kernel.org
Cc: corbet@lwn.net; Matthew Gerlach <redacted>
Subject: Re: [PATCH v1 7/7] fpga: dfl: pci: Add generic OFS PCI PID


On 2/14/22 3:26 AM, Tianfei zhang wrote:
quoted
From: Matthew Gerlach <redacted>

Add the PCI product id for an Open FPGA Stack PCI card.
Is there a URL to the card ?
This PCIe Device IDs have registered by Intel.
A URL is useful to introduce the board, Is there one ?
quoted
quoted
Signed-off-by: Matthew Gerlach <redacted>
Signed-off-by: Tianfei Zhang <redacted>
---
   drivers/fpga/dfl-pci.c | 4 ++++
   1 file changed, 4 insertions(+)
diff --git a/drivers/fpga/dfl-pci.c b/drivers/fpga/dfl-pci.c index
83b604d6dbe6..cb2fbf3eb918 100644
--- a/drivers/fpga/dfl-pci.c
+++ b/drivers/fpga/dfl-pci.c
@@ -76,12 +76,14 @@ static void cci_pci_free_irq(struct pci_dev *pcidev)
   #define PCIE_DEVICE_ID_INTEL_PAC_D5005		0x0B2B
   #define PCIE_DEVICE_ID_SILICOM_PAC_N5010	0x1000
   #define PCIE_DEVICE_ID_SILICOM_PAC_N5011	0x1001
+#define PCIE_DEVICE_ID_INTEL_OFS		0xbcce
INTEL_OFS is a generic name, pci id's map to specific cards

Is there a more specific name for this card ?
I think using INTEL_OFS is better, because INTEL_OFS is the Generic development platform can support multiple cards which using OFS specification,
like Intel PAC N6000 card.
I would prefer something like PCIE_DEVICE_ID_INTEL_PAC_N6000 because it 
follows an existing pattern.  Make it easy on a developer, they will 
look at their board or box, see X and try to find something similar in 
the driver source.

To use OSF_ * the name needs a suffix to differentiate it from future 
cards that will also use ofs.

If this really is a generic id please explain in the doc patch how every 
future board with use this single id and how a driver could work around 
a hw problem in a specific board with a pci id covering multiple boards.

Tom
quoted
Tom
quoted
   /* VF Device */
   #define PCIE_DEVICE_ID_VF_INT_5_X		0xBCBF
   #define PCIE_DEVICE_ID_VF_INT_6_X		0xBCC1
   #define PCIE_DEVICE_ID_VF_DSC_1_X		0x09C5
   #define PCIE_DEVICE_ID_INTEL_PAC_D5005_VF	0x0B2C
+#define PCIE_DEVICE_ID_INTEL_OFS_VF		0xbccf

   static struct pci_device_id cci_pcie_id_tbl[] = {
   	{PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCIE_DEVICE_ID_PF_INT_5_X),},
@@
quoted
-95,6 +97,8 @@ static struct pci_device_id cci_pcie_id_tbl[] = {
   	{PCI_DEVICE(PCI_VENDOR_ID_INTEL,
PCIE_DEVICE_ID_INTEL_PAC_D5005_VF),},
quoted
   	{PCI_DEVICE(PCI_VENDOR_ID_SILICOM_DENMARK,
PCIE_DEVICE_ID_SILICOM_PAC_N5010),},
quoted
   	{PCI_DEVICE(PCI_VENDOR_ID_SILICOM_DENMARK,
PCIE_DEVICE_ID_SILICOM_PAC_N5011),},
+	{PCI_DEVICE(PCI_VENDOR_ID_INTEL, PCIE_DEVICE_ID_INTEL_OFS),},
+	{PCI_DEVICE(PCI_VENDOR_ID_INTEL,
PCIE_DEVICE_ID_INTEL_OFS_VF),},
quoted
   	{0,}
   };
   MODULE_DEVICE_TABLE(pci, cci_pcie_id_tbl);
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help