Thread (18 messages) flat view 18 messages, 4 authors, 2021-09-20

Re: [PATCH v5 2/8] configfs: use BIT() for internal flags

From: Bartosz Golaszewski <hidden>
Date: 2021-09-20 14:14:39
Also in: linux-gpio, lkml

On Mon, Sep 20, 2021 at 4:09 PM Christoph Hellwig [off-list ref] wrote:
On Mon, Sep 20, 2021 at 04:05:03PM +0200, Bartosz Golaszewski wrote:
quoted
For better readability and maintenance: use the BIT() macro for flag
definitions.
NAK.  BIT() is the stupidest macro in the kernel and shall not be used
ever.  And I'm pretty sure we had this discussion a few times.
Yep and the general consensus among the kernel developers still is to
use the BIT() macro. Even for this patch there were three separate
comments from high-profile developers to use BIT().

Also: this really is bikeshedding at this point, given that the core
subject of this series is elsewhere.

Bart
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help