On Wed, 25 Aug 2021 10:54:46 -0500
Bjorn Helgaas [off-list ref] wrote:
On Wed, Aug 25, 2021 at 04:51:35PM +0300, Yishai Hadas wrote:
quoted
From: Max Gurtovoy <mgurtovoy@nvidia.com>
Add 'override_only' field to struct pci_device_id to be used as part of
pci_match_device().
When set, it means that matching is true only when dev->driver_override
is this driver.
Maybe:
When set, a driver only matches the entry when dev->driver_override
is set to that driver.
I've made this change locally, thanks Bjorn.
Alex
quoted
In addition, add a helper macro named 'PCI_DEVICE_DRIVER_OVERRIDE' to
enable setting some data on it.
Next patch from this series will use the above functionality.
Signed-off-by: Max Gurtovoy <mgurtovoy@nvidia.com>
Signed-off-by: Jason Gunthorpe <jgg@nvidia.com>
Signed-off-by: Yishai Hadas <yishaih@nvidia.com>
Acked-by: Bjorn Helgaas <bhelgaas@google.com>