Re: [PATCH v2 01/12] docs: path-lookup: update follow_managed() part
From: Jonathan Corbet <corbet@lwn.net>
Date: 2021-04-19 19:22:38
Also in:
lkml
Fox Chen [off-list ref] writes:
On Mon, Apr 19, 2021 at 11:25 AM Matthew Wilcox [off-list ref] wrote:quoted
On Mon, Apr 19, 2021 at 10:33:00AM +0800, Fox Chen wrote:quoted
On Mon, Apr 19, 2021 at 10:17 AM Matthew Wilcox [off-list ref] wrote:quoted
You can drop ``..`` from around function named which are followed with (). d74b0d31ddde ("Docs: An initial automarkup extension for sphinx") marks them up automatically.Got it, thanks for letting me know. But I will still use them in this patch series to keep consistency with the remaining parts of the document.Well, you weren't. For example: +As the last step of ``walk_component()``, ``step_into()`` will be called either +directly from walk_component() or from handle_dots(). It calls +``handle_mount()``, to check and handle mount points, in which a new Neither of the functions on the second line were using ``.Oh, That was a mistake, They should've been wrapped with ``. Thanks for pointing it out. I will go through the whole patch set and fix this type of inconsistency in V3.
Please, if possible, go toward the bare function() form rather than using literals...it's easier to read and the docs system will automatically create cross references for you. Thanks, jon