Re: [RFC PATCH 1/6] security/fbfam: Add a Kconfig to enable the fbfam feature
From: John Wood <hidden>
Date: 2020-09-18 14:52:13
Also in:
linux-fsdevel, linux-security-module, lkml
From: John Wood <hidden>
Date: 2020-09-18 14:52:13
Also in:
linux-fsdevel, linux-security-module, lkml
On Thu, Sep 17, 2020 at 03:05:18PM -0700, Kees Cook wrote:
On Thu, Sep 17, 2020 at 08:40:06PM +0200, John Wood wrote:quoted
quoted
To jump on the bikeshed: how about just calling this FORK_BRUTE_FORCE_DETECTION or FORK_BRUTE, and the directory could be "brute", etc. "fbfam" doesn't tell anyone anything.Understood. But how about use the fbfam abbreviation in the code? Like as function name prefix, struct name prefix, ... It would be better to use a more descriptive name in this scenario? It is not clear to me.I don't feel too strongly, but I think having the CONFIG roughly match the directory name, roughly match the function prefixes should be best. Maybe call the directory and function prefix "brute"?
Thanks for the clarification.
-- Kees Cook
Regards, John Wood