Re: [PATCH] Security: Documentation: fix: `make htmldocs` warnings
From: Puranjay Mohan <hidden>
Date: 2020-07-06 18:21:18
Also in:
linux-kernel-mentees, lkml
On Mon, Jul 6, 2020 at 11:44 PM Jonathan Corbet [off-list ref] wrote:
On Mon, 6 Jul 2020 23:30:10 +0530 Puranjay Mohan [off-list ref] wrote:quoted
Remove extra ')' after function name to fix warnings. It solves following warning : WARNING: Unparseable C cross-reference: 'groups_sort)' Invalid C declaration: Expected end of definition. [error at 11] Signed-off-by: Puranjay Mohan <redacted> --- Documentation/security/credentials.rst | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)diff --git a/Documentation/security/credentials.rst b/Documentation/security/credentials.rst index 282e79feee6a..d51e42b92395 100644 --- a/Documentation/security/credentials.rst +++ b/Documentation/security/credentials.rst@@ -455,7 +455,7 @@ When replacing the group list, the new list must be sorted before it is added to the credential, as a binary search is used to test for membership. In practice, this means :c:func:`groups_sort` should be called before :c:func:`set_groups` or :c:func:`set_current_groups`. -:c:func:`groups_sort)` must not be called on a ``struct group_list`` which +:c:func:`groups_sort` must not be called on a ``struct group_list`` which is shared as it may permute elements as part of the sorting process even if the array is already sorted.So this is a great fix, thanks for sending it. That said, there are a couple of ways in which this fix can be made even better: - The simpler of the two is to change the subject line of the patch. "Fix a warning" is almost never a good description of what you're doing; what you are actually doing is fixing a broken cross reference. So the subject line should say that. - In this case, though, there is a much better thing to do. We deprecated the use of :c:func: around a year ago; the docs build system can now do the right thing automatically. So a fix that would both eliminate the warning and improve the document as a whole would be to replace every instance of: :c:func:`function_name` with: function_name() Is there any chance I could get you to send a patch that does that?
Yes! I have started working on it.
Thanks, jon
Thanks, Puranjay