Thread (46 messages) 46 messages, 10 authors, 2020-06-12

Re: [PATCH v3 0/7] Venus dynamic debug

From: Joe Perches <joe@perches.com>
Date: 2020-06-09 16:49:40
Also in: linux-acpi, linux-arm-msm, linux-btrfs, linux-media, lkml, netdev

(adding Jim Cromie and comments)

On Tue, 2020-06-09 at 09:03 -0700, Randy Dunlap wrote:
On 6/9/20 4:13 AM, Matthew Wilcox wrote:
quoted
On Tue, Jun 09, 2020 at 01:45:57PM +0300, Stanimir Varbanov wrote:
quoted
Here is the third version of dynamic debug improvements in Venus
driver.  As has been suggested on previous version by Joe [1] I've
made the relevant changes in dynamic debug core to handle leveling
as more generic way and not open-code/workaround it in the driver.

About changes:
 - added change in the dynamic_debug and in documentation
 - added respective pr_debug_level and dev_dbg_level
Honestly, this seems like you want to use tracepoints, not dynamic debug.
Tracepoints are a bit heavy and do not have any class
or grouping mechanism.

debug_class is likely a better name than debug_level
Also see this patch series:
https://lore.kernel.org/lkml/20200605162645.289174-1-jim.cromie@gmail.com/ (local)
[PATCH 00/16] dynamic_debug: cleanups, 2 features

It adds/expands dynamic debug flags quite a bit.
Yes, and thanks Randy and Jim and Stanimir

I haven't gone through Jim's proposal enough yet.
It's unfortunate these patches series conflict.

And for Jim, a link to Stanimir's patch series:
https://lore.kernel.org/lkml/20200609104604.1594-1-stanimir.varbanov@linaro.org/ (local)

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help