On Mon, Mar 09, 2020 at 03:48:55PM -0500, Eric W. Biederman wrote:
And I completely agree that we should at least rename tsk to me.
Just for clarity.
I think it wouldn't hurt to add comments to spell it out explicitly
in each of the tsk->me functions, something like:
/*
* The "me" task_struct argument here must only ever refer to "current",
* but it gets passed in to avoid re-calculating "current" in each helper.
*/
I've found that the exec code in its entirety would be better off with
more comments. :) Usually that's the bulk of what I find myself adding
when I make changes in this area. ;)
-Kees
--
Kees Cook