Thread (4 messages) flat view 4 messages, 2 authors, 2019-07-12

Re: [PATCH] treewide: Rename rcu_dereference_raw_notrace to _check

From: Joel Fernandes <hidden>
Date: 2019-07-11 20:50:42
Also in: linuxppc-dev, lkml, rcu

On Thu, Jul 11, 2019 at 4:45 PM Joel Fernandes (Google)
[off-list ref] wrote:
The rcu_dereference_raw_notrace() API name is confusing.
It is equivalent to rcu_dereference_raw() except that it also does
sparse pointer checking.

There are only a few users of rcu_dereference_raw_notrace(). This
patches renames all of them to be rcu_dereference_raw_check with the
"check" indicating sparse checking.

Signed-off-by: Joel Fernandes (Google) <redacted>
There also these _notrace things but I am Ok with leaving them alone for now:
hash_for_each_possible_rcu_notrace
hlist_for_each_entry_rcu_notrace

- Joel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help