Thread (17 messages) 17 messages, 4 authors, 2019-05-28

Re: [PATCH RFC 0/5] Remove some notrace RCU APIs

From: Paul E. McKenney <hidden>
Date: 2019-05-25 15:50:46
Also in: linuxppc-dev, lkml, rcu

On Sat, May 25, 2019 at 10:19:54AM -0400, Joel Fernandes wrote:
On Sat, May 25, 2019 at 07:08:26AM -0400, Steven Rostedt wrote:
quoted
On Sat, 25 May 2019 04:14:44 -0400
Joel Fernandes [off-list ref] wrote:
quoted
quoted
I guess the difference between the _raw_notrace and just _raw variants
is that _notrace ones do a rcu_check_sparse(). Don't we want to keep
that check?  
This is true.

Since the users of _raw_notrace are very few, is it worth keeping this API
just for sparse checking? The API naming is also confusing. I was expecting
_raw_notrace to do fewer checks than _raw, instead of more. Honestly, I just
want to nuke _raw_notrace as done in this series and later we can introduce a
sparse checking version of _raw if need-be. The other option could be to
always do sparse checking for _raw however that used to be the case and got
changed in http://lists.infradead.org/pipermail/linux-afs/2016-July/001016.html
What if we just rename _raw to _raw_nocheck, and _raw_notrace to _raw ?
That would also mean changing 160 usages of _raw to _raw_nocheck in the
kernel :-/.

The tracing usage of _raw_notrace is only like 2 or 3 users. Can we just call
rcu_check_sparse directly in the calling code for those and eliminate the APIs?

I wonder what Paul thinks about the matter as well.
My thought is that it is likely that a goodly number of the current uses
of _raw should really be some form of _check, with lockdep expressions
spelled out.  Not that working out what exactly those lockdep expressions
should be is necessarily a trivial undertaking.  ;-)

That aside, if we are going to change the name of an API that is
used 160 places throughout the tree, we would need to have a pretty
good justification.  Without such a justification, it will just look
like pointless churn to the various developers and maintainers on the
receiving end of the patches.

							Thanx, Paul
thanks, Steven!
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help