Re: [PATCH v10 2/9] cpuset: Add new v2 cpuset.sched.domain_root flag
From: Waiman Long <longman@redhat.com>
Date: 2018-06-21 08:05:30
Also in:
cgroups, lkml
On 06/21/2018 03:58 PM, Waiman Long wrote:
On 06/20/2018 10:27 PM, Peter Zijlstra wrote:quoted
On Mon, Jun 18, 2018 at 12:14:01PM +0800, Waiman Long wrote:quoted
+ cpuset.sched.domain_rootWhy are we calling this a domain_root and not a partition?A partition can consist of several cgroups in a tree structure. That flag should only be set at the root of a partition. I will change the name to partition_root if you think this name is acceptable.quoted
quoted
+ A read-write single value file which exists on non-root + cpuset-enabled cgroups. It is a binary value flag that accepts + either "0" (off) or "1" (on). This flag is set by the parent + and is not delegatable.You still haven't answered: , https://lkml.kernel.org/r/20180531094943.GG12180@hirez.programming.kicks-ass.net the question stands.I am sorry to miss your question. Turning on domain_root will affects the cpu mapping in the parent. That is why it cannot be set by the child as a child is not supposed to be able to affect the parent.
After thinking a bit more about it, you are right that I should not use the term "not delegatable" here. I will rephrase in the next version. Cheers, Longman -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html