On 9/25/26 03:16, Andrew Lunn wrote:
quoted
quoted
+$ref: ethernet-phy-package.yaml#
+
+properties:
+ compatible:
+ enum:
+ - motorcomm,yt8824-package
+ phy-mode:
+ $ref: /schemas/types.yaml#/definitions/string
+ enum: [ internal, 10g-qxgmii ]
This should be after ref, but also have a vendor prefix.
Additionally, the qcom ethernet-phy-package user also has a mode
property. Net folks, should this be made common?
phy-mode is definitely wrong, it has a different meaning, and reusing
it is just going to cause confusion.
qcom,package-mode does have the same meaning as what is trying to be
expressed here. So yes, a common, vendor independent property would
make sense. It maybe should be in ethernet-phy-package.
Ans: okay, In the next version, I will revert the previous
implementation and follow the qcom,package-related approach.
Andrew