Thread (8 messages) 8 messages, 2 authors, 4d ago

Re: [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S SoM platform

From: sashiko-bot@kernel.org
Date: 2026-07-08 12:30:59
Also in: linux-phy

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The top-level GPIO keys node is incorrectly named `gpio-key` instead of the standard `gpio-keys`.
--
--- Patch [4]: [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S SoM platform ---
commit e39fa2dd470c78fd482e4061f2bce87250dda523
Author: Komal Bajaj [off-list ref]

arm64: dts: qcom: Add Shikra IQ2390S SoM platform

This commit adds the device tree include for the IQ2390S variant of the
Shikra System-on-Module. It includes the common shikra.dtsi and adds
PM8150 PMIC regulator definitions specific to this variant.
quoted hunk ↗ jump to hunk
diff --git a/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi b/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi
new file mode 100644
index 0000000000000..73945bf42112d
--- /dev/null
+++ b/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi
@@ -0,0 +1,170 @@
+// SPDX-License-Identifier: BSD-3-Clause
+/*
+ * Copyright (c) Qualcomm Technologies, Inc. and/or its subsidiaries.
+ */
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
+
+#include "shikra.dtsi"
+#include "pm8150.dtsi"
+
+/ {
+	gpio-key {
+		compatible = "gpio-keys";
[Severity: Low]
This isn't a bug, but is this top-level node named correctly? Devicetree
conventions typically use standard generic names like gpio-keys across the
subsystem rather than the singular gpio-key. 
+		label = "gpio-keys";
+		pinctrl-names = "default";
+		pinctrl-0 = <&vol_up_n>;
[ ... ]

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260708-shikra-dt-v7-0-977b65a300c1@oss.qualcomm.com?part=4
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help