Re: [PATCH v3 7/9] ASoC: dt-bindings: loongson,ls-audio-card: Add ATK-DL2K0300B compatible
From: sashiko-bot@kernel.org
Date: 2026-06-26 02:38:48
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] Custom GPIO properties lack a vendor prefix. -- commit ad0ddc0bcb1797ef1e44f8d7b02415a3c55eb74b Author: Binbin Zhou [off-list ref] ASoC: dt-bindings: loongson,ls-audio-card: Add ATK-DL2K0300B compatible This commit adds a new compatible string for the ATK-DL2K0300B development board based on Loongson-2K0300. It also introduces several new GPIO properties to support hardware features like speaker enable and headphone detection.
quoted hunk ↗ jump to hunk
diff --git a/Documentation/devicetree/bindings/sound/loongson,ls-audio-card.yaml b/Documentation/devicetree/bindings/sound/loongson,ls-audio-card.yaml --- a/Documentation/devicetree/bindings/sound/loongson,ls-audio-card.yaml +++ b/Documentation/devicetree/bindings/sound/loongson,ls-audio-card.yaml
[ ... ]
quoted hunk ↗ jump to hunk
@@ -47,6 +48,18 @@ properties: required: - sound-dai + spkr-en-gpios: + maxItems: 1 + description: The GPIO that enables the speakers + + hp-ctl-gpios: + maxItems: 1 + description: The GPIO that control the headphones
[Severity: Low] This isn't a bug, but should these custom board-specific GPIO properties include a vendor prefix? Since they are unique and non-standard properties, using a prefix like loongson,spkr-en-gpios and loongson,hp-ctl-gpios would better align with device tree naming conventions.
+ + hp-det-gpios: + maxItems: 1 + description: The GPIO that detect headphones are plugged in
-- Sashiko AI review · https://sashiko.dev/#/patchset/cover.1782439646.git.zhoubinbin@loongson.cn?part=7