Thread (7 messages) 7 messages, 4 authors, 2026-03-02

Re: [RFC PATCH 2/2] arm64: dts: imx8mp-frdm: Use symbolic macros for IOMUXC_SW_PAD_CTL_PAD

From: Maud Spierings <maudspierings@gocontroll.com>
Date: 2026-02-27 13:33:47
Also in: imx, linux-arm-kernel, lkml

Hi Daniel,

On 2/27/26 14:02, Daniel Baluta wrote:
Currently, in order to configure IOMUXC_SW_PAD_CTL_PAD a magic raw value
is written in this register. This makes code not obvious to read and
modify.

So, to help with code readability instead of the magic values use
symbolic macros.

Signed-off-by: Daniel Baluta <daniel.baluta@nxp.com>
---
  arch/arm64/boot/dts/freescale/imx8mp-frdm.dts | 132 +++++++++++-------
  .../arm64/boot/dts/freescale/imx8mp-pinfunc.h |   2 +
  2 files changed, 86 insertions(+), 48 deletions(-)
[snip]
quoted hunk ↗ jump to hunk
diff --git a/arch/arm64/boot/dts/freescale/imx8mp-pinfunc.h b/arch/arm64/boot/dts/freescale/imx8mp-pinfunc.h
index 26e7a9428c4c7..c963913e3c626 100644
--- a/arch/arm64/boot/dts/freescale/imx8mp-pinfunc.h
+++ b/arch/arm64/boot/dts/freescale/imx8mp-pinfunc.h
@@ -38,6 +38,8 @@
  				  MX8MP_HYS_SCHMITT | MX8MP_PULL_ENABLE)
  #define MX8MP_I2C_DEFAULT (MX8MP_PULL_UP | MX8MP_HYS_SCHMITT | \
  			   MX8MP_PULL_ENABLE | MX8MP_SION)
+#define MX8MP_NAND_DATA_DEFAULT (MX8MP_FSEL_FAST | MX8MP_PULL_UP | \
+				 MX8MP_HYS_SCHMITT | MX8MP_PULL_ENABLE)
Isn't this the same as the USDHC default that is above the i2c one?

Kind regards,
Maud
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help