Thread (15 messages) 15 messages, 3 authors, 2026-02-24

Re: [PATCH 05/10] ARM: dts: imx51-babbage: rename at45db321d@1 to flash@1

From: Daniel Baluta <hidden>
Date: 2026-02-03 13:56:20
Also in: imx, linux-arm-kernel, lkml

On Mon, Feb 2, 2026 at 9:45 PM Frank Li [off-list ref] wrote:
Rename at45db321d@1 to flash@1 to fix below CHECK_DTBS warnings:
at45db321d@1 (atmel,at45db321d): $nodename:0: 'at45db321d@1' does not match '^(flash|.*sram|nand)(@.*)?$'
        from schema $id: http://devicetree.org/schemas/mtd/atmel,dataflash.yaml
The commit message should say *why* the commit is needed and not
focus on fixing the warnings from a tool.

e.g:

ARM: dts: imx51-babbage: Use generic name for flash node

Prefer generic node name 'flash' over the existing specific one to reflect
the function of the device.

This fixes below CHECK_DTBS warning:
 at45db321d@1 (atmel,at45db321d): $nodename:0: 'at45db321d@1' does not
match '^(flash|.*sram|nand)(@.*)?$'
         from schema $id: http://devicetree.org/schemas/mtd/atmel,dataflash.yaml

<snip>
-       flash: at45db321d@1 {
+       flash: flash@1 {
                #address-cells = <1>;
                #size-cells = <1>;
                compatible = "atmel,at45db321d", "atmel,at45", "atmel,dataflash";
Thanks,
Daniel.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help