On Wed, Jan 28, 2026 at 10:43:35AM +0000, Russell King (Oracle) wrote:
On Wed, Jan 28, 2026 at 03:29:29PM +0800, Inochi Amaoto wrote:
quoted
+#include <linux/clk.h>
+#include <linux/math.h>
+#include <linux/mod_devicetable.h>
+#include <linux/module.h>
+#include <linux/mfd/syscon.h>
+#include <linux/of.h>
+#include <linux/platform_device.h>
+#include <linux/property.h>
+#include <linux/regmap.h>
+
+#include "stmmac_platform.h"
+
+/* ctrl register bits */
+#define PHY_INTF_RGMII BIT(3)
+#define PHY_INTF_MII BIT(4)
Please add a suitable prefix for these.
quoted
+
+#define WAKE_IRQ_EN BIT(9)
+#define PHY_IRQ_EN BIT(12)
While you're renaming the PHY_INTF_*, you might wish to also add the
same prefix here to identify that they're all part of the same register.
I think this is good for me. I will add the "CTRL" prefix
to identify these are all from ctrl register.
Regards,
Inochi