Thread (29 messages) 29 messages, 4 authors, 2026-01-27

Re: [PATCH v10 5/7] qcom-tgu: Add support to configure next action

From: Konrad Dybcio <hidden>
Date: 2026-01-27 10:32:26
Also in: linux-arm-kernel, linux-arm-msm, lkml

On 1/27/26 3:43 AM, Songwei Chai wrote:

On 1/13/2026 7:15 PM, Konrad Dybcio wrote:
quoted
On 1/9/26 3:11 AM, Songwei Chai wrote:
quoted
Add "select" node for each step to determine if another step is taken,
trigger(s) are generated, counters/timers incremented/decremented, etc.

Signed-off-by: Songwei Chai <redacted>
---
[...]
quoted
quoted
+    select = devm_kzalloc(dev, select_size, GFP_KERNEL);
+
+    if (!select)
stray \n
Will improve this based on the comments above.
quoted
quoted
+        return -ENOMEM;
+
+    drvdata->value_table->condition_select = select;
I don't see a need for an intemediate variable here
This was done intentionally, following the earlier suggestion in v9 to
introduce named intermediate variables for better readability when dealing with allocations.

I’m happy to inline the allocation if you prefer the simpler form here.
I don't mind that much

Konrad
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help