Thread (16 messages) 16 messages, 4 authors, 2025-10-20

Re: [PATCH v2 3/5] scsi: ufs: mediatek: Move MTK_SIP_UFS_CONTROL to mtk_sip_svc.h

From: Peter Wang (王信友) <peter.wang@mediatek.com>
Date: 2025-10-17 06:53:14
Also in: linux-arm-kernel, linux-mediatek, linux-phy, linux-scsi, lkml

On Thu, 2025-10-16 at 14:06 +0200, Nicolas Frattaroli wrote:
SMC commands used by multiple drivers need to live in a shared header
file somewhere to avoid code duplication. In order to rework the MPHY
reset control to be in the phy-mtk-ufs.c driver, both ufs-mediatek
and
the phy driver need access to this command.

Move it to mtk_sip_svc.h, where other such command definitions
already
live.

Reviewed-by: AngeloGioacchino Del Regno
[off-list ref]
Signed-off-by: Nicolas Frattaroli <nicolas.frattaroli@collabora.com>
Reviewed-by: Peter Wang <peter.wang@mediatek.com>

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help