Re: [PATCH v3 2/4] dt-bindings: leds: commonize leds property
From: Aleksandrs Vinarskis <hidden>
Date: 2025-09-08 10:47:41
Also in:
dri-devel, linux-arm-msm, linux-leds, linux-media, lkml
On Monday, September 8th, 2025 at 09:36, Konrad Dybcio [off-list ref] wrote:
On 9/8/25 9:33 AM, Hans de Goede wrote:quoted
Hi, On 8-Sep-25 09:20, Konrad Dybcio wrote:quoted
On 9/8/25 1:18 AM, Aleksandrs Vinarskis wrote:quoted
A number of existing schemas use 'leds' property to provide phandle-array of LED(s) to the consumer. Additionally, with the upcoming privacy-led support in device-tree, v4l2 subnode could be a LED consumer, meaning that all camera sensors should support 'leds' and 'led-names' property via common 'video-interface-devices.yaml'. To avoid dublication, commonize 'leds' property from existing schemas to newly introduced 'led-consumer.yaml'. Signed-off-by: Aleksandrs Vinarskis alex@vinarskis.com ---[...]quoted
+ leds: + minItems: 1 + maxItems: 1My brain compiler suggests this will throw a warning (minItems should be redundant in this case)
No complaints when running `dt_bindings_check` on this nor the camera sensor that uses this binding. I thought it would be better to keep it even though right now only one LED is supported, so that when `led-names` are extended with new functions, one can just bump maxItems and not accidentally forget to introduce minItems. No strong opinion though, perhaps Rob can decide since he is the one that suggested to add minItems,maxItems that I didn't think of?
quoted
quoted
quoted
+ + led-names: + enum: + - privacy-ledNit: "privacy" makes more sense without the suffix, as we inherently know this is supposed to be an LEDNote "privacy-led" as name is already used on the x86/ACPI side and the code consuming this will be shared. With that said if there is a strong preference for going with just "privacy" the x86 side can be adjusted since the provider-info is generated through a LED lookup table on the x86/ACPI side. So we can just modify both the lookup table generation as well as the already existing led_get(dev, "privacy-led") call to use just "privacy" without problems.In that case, it may be cleaner to just go with what we have today (unless the dt maintainers have stronger opinions)
Sounds good, thanks both for the feedback. Alex
Konrad