Re: [PATCH 2/2] leds: led-class: Add devicetree support to led_get()
From: Lee Jones <lee@kernel.org>
Date: 2025-09-03 06:58:47
Also in:
linux-leds, lkml
From: Lee Jones <lee@kernel.org>
Date: 2025-09-03 06:58:47
Also in:
linux-leds, lkml
On Wed, 03 Sep 2025, Linus Walleij wrote:
On Tue, Sep 2, 2025 at 1:10 PM Aleksandrs Vinarskis [off-list ref] wrote:quoted
From: Hans de Goede <hansg@kernel.org> Turn of_led_get() into a more generic __of_led_get() helper function, which can lookup LEDs in devicetree by either name or index.I don't really like __inner_function() as naming since it is easily confused with __COMPILER_FLAGS__ and also with __non_atomic_bitset(). I would name it of_led_get_inner() simply.
I'm personally okay with '__' to mean private. There are many examples of this already. I'm generally less happy with '__' functions being exported or otherwise used outside of the subsystem / core that they reside in. -- Lee Jones [李琼斯]