Re: [PATCH] dt-bindings: pci: brcmstb: Add rp1-nexus node to fix DTC warning
From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2025-08-22 06:50:24
Also in:
linux-arm-kernel, linux-pci, lkml
On 21/08/2025 17:22, Andrea della Porta wrote:
Hi Krzysztof, On 10:55 Tue 12 Aug , Krzysztof Kozlowski wrote:quoted
On 12/08/2025 10:50, Andrea della Porta wrote:quoted
The devicetree compiler is complaining as follows: arch/arm64/boot/dts/broadcom/rp1-nexus.dtsi:3.11-14.3: Warning (unit_address_vs_reg): /axi/pcie@1000120000/rp1_nexus: node has a reg or ranges property, but no unit name /home/andrea/linux-torvalds/arch/arm64/boot/dts/broadcom/bcm2712-rpi-5-b.dtb: pcie@1000120000: Unevaluated properties are not allowed ('rp1_nexus' was unexpected)Please trim the paths.Ack.quoted
quoted
Add the optional node that fix this to the DT binding. Reported-by: kernel test robot <redacted> Closes: https://lore.kernel.org/oe-kbuild-all/202506041952.baJDYBT4-lkp@intel.com/ (local) Signed-off-by: Andrea della Porta <andrea.porta@suse.com> --- Documentation/devicetree/bindings/pci/brcm,stb-pcie.yaml | 9 +++++++++ 1 file changed, 9 insertions(+)diff --git a/Documentation/devicetree/bindings/pci/brcm,stb-pcie.yaml b/Documentation/devicetree/bindings/pci/brcm,stb-pcie.yaml index 812ef5957cfc..7d8ba920b652 100644 --- a/Documentation/devicetree/bindings/pci/brcm,stb-pcie.yaml +++ b/Documentation/devicetree/bindings/pci/brcm,stb-pcie.yaml@@ -126,6 +126,15 @@ required: allOf: - $ref: /schemas/pci/pci-host-bridge.yaml# - $ref: /schemas/interrupt-controller/msi-controller.yaml# + - if: + properties: + compatible: + contains: + const: brcm,bcm2712-pcie + then: + properties: + rp1_nexus:No, you cannot document post-factum... This does not follow DTS coding style.I think I didn't catch what you mean here: would that mean that we cannot resolve that warning since we cannot add anything to the binding?
I meant, you cannot use a warning from the code you recently introduced as a reason to use incorrect style. Fixing warning is of course fine and correct, but for the code recently introduced and which bypassed ABI review it is basically like new review of new ABI. This needs standard review practice, so you need to document WHY you need such node. Warning is not the reason here why you are doing. If this was part of original patchset, like it should have been, you would not use some imaginary warning as reason, right? So provide reason why you need here this dedicated child, what is that child representing. Otherwise I can suggest: drop the child and DTSO, this also solves the warning...
Regarding rp1_nexus, you're right I guess it should be rp1-nexus as per DTS coding style.quoted
Also: Node names should be generic. See also an explanation and list of examples (not exhaustive) in DT specification: https://devicetree-specification.readthedocs.io/en/latest/chapter2-devicetree-basics.html#generic-names-recommendationIn this case it could be difficult: we need to search for a DT node
Search like in driver? That's wrong, you should be searching by compatible.
starting from the DT root and using generic names like pci@0,0 or dev@0,0 could possibly led to conflicts with other peripherals. That's why I chose a specific name.
Dunno, depends what can be there, but you do not get a specific (non-generic) device node name for a generic PCI device or endpoint. Best regards, Krzysztof