Re: [PATCH v3] ARM: dts: renesas: r9a06g032-rzn1d400-db: describe Debug LEDs
From: Lee Jones <lee@kernel.org>
Date: 2025-05-08 13:49:35
Also in:
linux-leds, linux-renesas-soc
On Thu, 08 May 2025, Wolfram Sang wrote:
On Thu, Apr 17, 2025 at 01:39:14PM +0200, Geert Uytterhoeven wrote:quoted
Hi Wolfram, CC leds On Thu, 17 Apr 2025 at 11:33, Wolfram Sang [off-list ref] wrote:quoted
Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com> --- Changes since v2: * using function, color, function-enumerator properties now Honestly, this is better than using node names? With V2, the LEDs were named as in the schematics, now they are called: lrwxrwxrwx 1 root root 0 May 12 12:10 green:programming-0 -> ../../devices/platform/leds/leds/green:programming-0 lrwxrwxrwx 1 root root 0 May 12 12:10 green:programming-1 -> ../../devices/platform/leds/leds/green:programming-1 lrwxrwxrwx 1 root root 0 May 12 12:10 green:programming-2 -> ../../devices/platform/leds/leds/green:programming-2 ... Which gets even more confusing if we might later add LEDs not on this board, but on the expansion board. 'green:programming-8' sits where? I really wonder, but if this is the official way now...Good point! So I'm inclined to take v2... Let's raise this with the LED people. I don't want to fight Pavel when v2 hits the CiP tree ;-)So, if there is no other opinion here, can we remove function, color, function-enumerator and just use the node names which match the schematics? Basically apply V2?
I didn't author the semantics nor the rules surrounding them, but I am obliged to enforce them. Therefore "LED people" say, please stick to convention as stated in the present documentation: https://docs.kernel.org/leds/leds-class.html#led-device-naming Please note that a "debug" (LED_FUNCTION_DEBUG) option already exists if that is more appropriate to your use-case. Let's also bring Jacek into the conversion, since I know that he did a bunch of work around this topic. -- Lee Jones [李琼斯]