Thread (11 messages) 11 messages, 2 authors, 2025-02-24

Re: [PATCH v10 3/6] dt-bindings: clock: Add ipq9574 NSSCC clock and reset definitions

From: Manikanta Mylavarapu <hidden>
Date: 2025-02-24 09:54:53
Also in: linux-arm-kernel, linux-arm-msm, linux-clk, lkml, netdev


On 2/21/2025 5:19 PM, Konrad Dybcio wrote:
On 21.02.2025 11:14 AM, Manikanta Mylavarapu wrote:
quoted
From: Devi Priya <redacted>

Add NSSCC clock and reset definitions for ipq9574.

Reviewed-by: Krzysztof Kozlowski <redacted>
Signed-off-by: Devi Priya <redacted>
Signed-off-by: Manikanta Mylavarapu <redacted>
---
[...]
quoted
+  - |
+    #include <dt-bindings/clock/qcom,ipq9574-gcc.h>
+    #include <dt-bindings/clock/qcom,ipq-cmn-pll.h>
+    clock-controller@39b00000 {
+      compatible = "qcom,ipq9574-nsscc";
+      reg = <0x39b00000 0x80000>;
+      clocks = <&xo_board_clk>,
+               <&cmn_pll NSS_1200MHZ_CLK>,
+               <&cmn_pll PPE_353MHZ_CLK>,
+               <&gcc GPLL0_OUT_AUX>,
+               <&uniphy 0>,
+               <&uniphy 1>,
+               <&uniphy 2>,
+               <&uniphy 3>,
+               <&uniphy 4>,
+               <&uniphy 5>,
+               <&gcc GCC_NSSCC_CLK>;
+      clock-names = "xo",
+                    "nss_1200",
+                    "ppe_353",
+                    "gpll0_out",
+                    "uniphy0_rx",
+                    "uniphy0_tx",
+                    "uniphy1_rx",
+                    "uniphy1_tx",
+                    "uniphy2_rx",
+                    "uniphy2_tx",
+                    "nsscc";
I see that the input clock is named rather non-descriptively, but maybe
we should call it something like "bus" so that it has more meaning to
the reader
Hi Konrad,

Thank you for reviewing the patch.
I will rename the 'nsscc' clock to 'bus' in the next version.

Thanks & Regards,
Manikanta.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help