Re: [PATCH RESEND v3 06/17] Documentation: ABI: add wideband filter type to sysfs-bus-iio
From: David Lechner <dlechner@baylibre.com>
Date: 2025-02-20 21:28:12
Also in:
linux-iio, lkml
From: David Lechner <dlechner@baylibre.com>
Date: 2025-02-20 21:28:12
Also in:
linux-iio, lkml
On 2/12/25 12:16 PM, Jonathan Santos wrote:
The Wideband Low Ripple filter is used for AD7768-1 Driver. Document wideband filter option into filter_type_available attribute. Signed-off-by: Jonathan Santos <redacted> --- v3 Changes: * None, since we still did not agree on a better name for this filter type.
I'm convinced at this point that "wideband" is fine.
v2 Changes: * Removed FIR mentions. --- Documentation/ABI/testing/sysfs-bus-iio | 2 ++ 1 file changed, 2 insertions(+)diff --git a/Documentation/ABI/testing/sysfs-bus-iio b/Documentation/ABI/testing/sysfs-bus-iio index f83bd6829285..9b879e7732cd 100644 --- a/Documentation/ABI/testing/sysfs-bus-iio +++ b/Documentation/ABI/testing/sysfs-bus-iio@@ -2291,6 +2291,8 @@ Description: * "sinc3+pf2" - Sinc3 + device specific Post Filter 2. * "sinc3+pf3" - Sinc3 + device specific Post Filter 3. * "sinc3+pf4" - Sinc3 + device specific Post Filter 4. + * "wideband" - filter with wideband low ripple passband + and sharp transition band.
The description could perhaps be made a bit more generic though instead of using specifics from the AD7768-1 datasheet. Something along the lines of Jonathan's 'flattish to a wide range of frequencies' description.
What: /sys/.../events/in_proximity_thresh_either_runningperiod KernelVersion: 6.6