On Thu, 15 Aug 2024 at 00:27, Detlev Casanova
[off-list ref] wrote:
Add support for the power domain controller on the rk3576 SoC.
Patches from downstream have been rebased.
Note that the mentioned TRM is not publicly available.
Changes since v3:
- Remove unused g_mask and reuse DOMAIN_M_O_R
Changes since v2:
- Remove unused delay for npu and vop
Changes since v1:
- Rename rk3576-power.h to rockchip,rk3576-power.h
- Add memory reset support
- Squashed header files with bindings commit
- Updated license
- Fix commit messages for subsystem.
Detlev.
Finley Xiao (2):
dt-bindings: power: Add support for RK3576 SoC
pmdomain: rockchip: Add support for RK3576 SoC
.../power/rockchip,power-controller.yaml | 1 +
drivers/pmdomain/rockchip/pm-domains.c | 45 +++++++++++++++++++
.../dt-bindings/power/rockchip,rk3576-power.h | 30 +++++++++++++
3 files changed, 76 insertions(+)
create mode 100644 include/dt-bindings/power/rockchip,rk3576-power.h
Applied for next, thanks!
Kind regards
Uffe